Port problem on Macbook Pro

It is my first time using an arduino uno and just when i try to set it up it wont work. I've tried to select the port on my mac and it doesn't seem to recognize it. I've also tried on a microsoft with windows 10 and it wouldn't recognize it even on Device Manager. I do not know what is the cause of this problem.
Other mentions:
Both computers have a c port so I use a usb to c adapter.

Does the arduino light up when you plug it in? If so, then perhaps look for software issues on the computer. If no, then the arduino is not getting power from the computer, and there is probably a physical connection issue somewhere between the computer and the arduino.

USB-to-C adapters seem to be problematic, if I must believe some posts on this forum. You will have to do the search.

Not even unknown devices or extra yellow exclamation marks when you connect?

Your mileage may vary, I have 3 different kinds and they all work flawlessly with my Uno or MEGA.

Try with a USB C to USB B direct cable - they exist.

image

@J-M-L, I was hoping that you would climb in :wink:

Check to see if the board has a corrupted bootloader. Check to see if the L-led blinks twice rapidly by pressing the reset button.

The arduino does light up. I've tried with 4 computers already and none of them recognize it.

I am now using a windows computer with a usb port and it won't recognize it.

The L led does blink twice when I rest it. What does that mean?

Good, that means your bootloader is functioning properly. As @sterretje mentioned does anything show in show in your device manager. Either in Other devices or Ports? Open your device manager then plug the usb to the port see if anything shows.


My arduino is plugged in and the leds are on. It doesn't recognize it.

So you have tried plugging it into a computer with a USB-A port?

If so, then the issue might be with your USB-A to USB-B cable, and not the USB-A to USB-C adaptor. Are you able to test the USB-B cable with any other device? (perhaps a printer)

Yes, I am now trying to use it with the usb-A port of my dell but it won't work either. I have checked the cable and it is working fine. I tried it with a printer as you said. I am starting to think the arduino UNO is deffective.

Yeah I suppose that would be a possibility. The arduino team members will probably be best for helping with this. Are there any visible damage on yours, and from where did you get it?

Also, just making sure you do have the arduino software installed on your computer right?

It would be so sad if your first arduino doesn't work. :sob:

Is it a true genuine Arduino or a clone?

To assist in answering this question compare it to How to spot a counterfeit Arduino

If it is a clone then you have to download the drivers for the USB chip it uses.

I don't see any damage in my arduino. I bought a starter kit from amazon two months ago. I am pretty sure the software is fine, I mean I tried it with other 4 computers :frowning: I have reached the arduino team for assistance. Thank you so much for your help :slight_smile:

1 Like

Pretty sure is the original one. It came with the starter kit.

I considered that posibility and downloaded some drivers but none of them worked :confused: