Problemi con Arduino Nano

Buongiorno a tutti,
sto tribolando con Arduino Nano, nel connetterlo al PC la selezione della porta seriale rimane "grigiata" e non c'è modo di selezionare la porta.
Ho provato a cambiare cavo USB ma niente da fare.
Ritengo che si possa trattare di problemi di driver, sto usando Windows 10, e dico questo perchè ho provato con un altro Arduino Nano (un compatibile, non originale Arduino) e ho lo stesso problema.
Qualcuno ha per caso avuto un problema simile e sa come uscirne ?
Grazie in anticipo a tutti

Arduino Nano (originale) monta come interfaccia Seiale <--> USB della FTDI ... molto probabilmente devi installare i driver aggiornati scaricandoli dal sito di FTDI.

Guglielmo

P.S.: Magari verifica sul retro della scheda che ci sia il chip della FTDI

Ah ... dimenticavo ... ti segnalo che, nella sezione in lingua Inglese, si può scrivere SOLO in Inglese ... quindi, per favore, la prossima volta presta più attenzione in quale sezione metti i tuoi post; questa volta esso è stato spostato, da un moderatore della sezione di lingua Inglese, nella sezione di lingua Italiana ... la prossima volta potrebbe venire direttamente eliminato ::slight_smile:

Guglielmo

Con i cloni Arduino Nano che ho avuto modo di acquistare, io ho sempre trovato montato il convertitore usb/ttl CH340 per il quale è necessario installare i driver con Windows 10.

Googlando un po' è venuto fuori questo link da dove poterli scaricare da un sito affidabile (SparkFun)

Driver CH340

Grazie mille per il supporto Guglielmo, e scusami per l'errata immissione del post, me ne sono reso conto solo dopo aver fatto invio ....

Grazie mille per l'indicazione, tenterò anche questa strada !!!!

Hai capito che chip montano i tuoi Nano ? Uno lo indichi come clone, ma l'altro?

Perché, come dice cotestatnt, potresti avere bisogno anche di driver differenti ... per gli originali (FTDI) e per i cloni (CH34x) ... :roll_eyes:

Guglielmo

Figurati..
Sempre sul sito SparkFun è presente anche questo video tutorial

https://learn.sparkfun.com/tutorials/how-to-install-ch340-drivers/all

Si, si, è chiarissimo.
Uno è Arduino originale comprato qui sullo Store Arduino, e quindi sicuramente monta un FTDI, l'altro l'ho comprato su AZDelivery e la documentazione associata dice chiaramente che c'è un CH340. Ora proverò l'aggiornamento dei driver e vi farò sapere (operazione da compiere "nottetempo" ..... :wink:)

Grazie mille, procederò in tal senso e ti farò sapere

Ciao Guglielmo e cotestatnt,
grazie alle vostre dritte ho risolto il problema.

Per il Nano ufficiale l'aggiornamento del driver ha sbloccato la porta seriale e mi ha consentito di completare la fase prototipale della mia nuova serratura a impronte digitali (vedi foto allegata), adesso può partire la fase di ingegnerizzazione finale.

Anche per il Nano "clone" l'aggiornamento del driver ha sbloccato la porta seriale, ma in questo caso ci sono altri problemi, appena lo sketch parte compaiono una serie di errori che devo decodificare e capire, ma avendo sbloccato il Nano ufficiale per ora metto queste cose a bassa priorità e le risolverò appena avrò tempo.

In conclusione grazie infinite per il vostro supporto !!!!

Per il clone occhio che non sia solo una questione di bootloader. Alcuni vengono venduti ancora col vecchio bootloader

Cmq a prescindere dalla provenienza della board, originale o clone che sia, lo stesso software deve funzionare in tutti e due i sistemi visto che il microcontrollore usato è lo stesso (ATmega328).

... salvo non siano cloni "monnezza" da pochi US$ e allora ... tutto è possibile ... :roll_eyes:

Guglielmo